ACL No account found.

  • Hello,

    i tried to setup my Server but when i tried to give myself admin permission it fails when i do ingame /login MyPassword it says No account found.

    I found another post which said that i should write instead of:

    XML
    1. <object name="User.DarkIce" password="My Password should be here" />
    2. <object name="user.DarkIce" password="My Password should be here" />

    Both dont work.


    Here is the acl.xml.

    Please help me :D

  • Compare your ACL and the example on the page ...

    Thanks for your answer it helped alot! I know have this acl.xml:





    I can /login and everything but as soon i type in /kick darkice test it gives me Net Error.


  • <?xml version="1.0"?>

    <acl xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

    <group name="Everyone">

    <acl name="Default" />

    <object name="user.*" />

    <object name="resource.*" />

    </group>

    <group name="Moderator">

    <acl name="Moderator" />

    </group>

    <group name="Admin">

    <acl name="Moderator" />

    <acl name="Admin" />

    <object name="User.lii12387" password="12345"/>

    <object name="User.Trelluder" password="1234567"/>

    <object name="User.Pott" password="12345678"/>

    <object name="User.sebii" password="123456"/>

    </group>

    <acl name="Default">

    <right name="command.kick" access="false" />

    <right name="command.ban" access="false" />

    <right name="command.stop" access="false" />

    <right name="command.start" access="false" />

    <right name="command.restart" access="false" />

    <right name="command.kill" access="false" />

    <right name="command.forcemap" access="false" />

    <right name="command.ghostmode" access="false" />

    <right name="command.settime" access="false" />

    <right name="command.setweather" access="false" />

    <right name="command.blackout" access="false" />

    </acl>

    <acl name="Moderator">

    <right name="command.kick" access="true" />

    <right name="command.ban" access="true" />

    <right name="command.kill" access="true" />

    <right name="command.forcemap" access="true" />

    <right name="command.ghostmode" access="true" />

    <right name="command.settime" access="true" />

    <right name="command.setweather" access="true" />

    <right name="command.blackout" access="true" />

    </acl>

    <acl name="Admin">

    <right name="command.stop" access="true" />

    <right name="command.start" access="true" />

    <right name="command.restart" access="true" />

    </acl>

    </acl>

  • Well that allows everyplayer to use the commands!

  • Hey which server do you host? I'm asking for science and research purposes. Promise.

  • how do I do that only on admin

    -_-

    Use this! But as i said i get an error when running the command

  • Hey which server do you host? I'm asking for science and research purposes. Promise.

    Ubuntu Server 16.04.3 LTS with mono:


    Mono JIT compiler version 5.4.1.6 (tarball Wed Nov 8 20:35:02 UTC 2017)

    Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. http://www.mono-project.com

    TLS: __thread

    SIGSEGV: altstack

    Notifications: epoll

    Architecture: amd64

    Disabled: none

    Misc: softdebug

    LLVM: supported, not enabled.

    GC: sgen (concurrent by default)



    mono-4.0-gac mono-gac mono-mcs mono-runtime mono-runtime-common mono-runtime-sgen libmono-accessibility4.0-cil libmono-btls-interface4.0-cil libmono-corlib4.5-cil libmono-cshar

    p4.0c-cil libmono-data-tds4.0-cil libmono-i18n-west4.0-cil libmono-i18n4.0-cil libmono-microsoft-csharp4.0-cil libmono-posix4.0-cil libmono-security4.0-cil libmono-system-configuration4.0-cil libmono-system-core

    4.0-cil libmono-system-data4.0-cil libmono-system-drawing4.0-cil libmono-system-enterpriseservices4.0-cil libmono-system-numerics4.0-cil libmono-system-runtime-serialization-formatters-soap4.0-cil libmono-system

    -runtime-serialization4.0-cil libmono-system-security4.0-cil libmono-system-servicemodel-internals0.0-cil libmono-system-transactions4.0-cil libmono-system-windows-forms4.0-cil libmono-system-xml4.0-cil libmono-

    system4.0-cil libmono-webbrowser4.0-cil